New Ticket

TICKET_CREATE privileges are required to perform this operation. You don't have the required permissions

Login Close

Unexpected DB caching behavior

Ticket #748 Assigned to nobody, last modified 4 years ago


Reporter rjollos
Keywords db
Type defect
Status closed
Priority critical
Product BHD
Component multiproduct


As discussed in #539, the unexpected DB caching behavior is seen in a TracStandalone environment with SQLite. The behavior can be reproduce with the following steps:

  1. Grant a permission to a subject through web admin.
  2. Refresh the page. On repeated refresh the action will sometimes be associated with the subject, and other times not. To make it "stick", tracd must be restarted.

Presumably, the following exhibits the same underlying issue:

  1. Rename a wiki page.
  2. View the TitleIndex page. Repeated refreshes will sometimes show the old page name, and sometimes the new page name.

This behavior was also reported on the mailing list.

Note: See TracTickets for help on using tickets.


I'm really tempted to mark this ticket as a duplicate of #685, #614 and a few more open issues across the web site , cmiiw (and reopen if appropriate)

  • Milestone Release 8 deleted - by rjollos, 4 years ago